Difference between revisions of "PiHPSDR"

From HPSDRwiki
Jump to: navigation, search
(Compiling PiHPSDR)
 
(6 intermediate revisions by the same user not shown)
Line 1: Line 1:
 +
 +
=== System Requirements ===
 +
 +
PiHPSDR is software designed to run on the Raspberry Pi using the official 7 inch touch screen.  It can be compiled to include support for Rotary Encoders and Push Buttons using the GPIO pins and/or the i2c interface.
 +
 +
It can be compiled and run on most Linux and Apple Mac systems without using GPIO.
 +
 +
It is recommended to use a Raspberry Pi 4 with 4GB or 8GB of memory if running Ubuntu 64bit OS.  The 2GB version will work OK using the Raspberry Pi 32 bit OS.
  
 
=== Compiling PiHPSDR ===
 
=== Compiling PiHPSDR ===
  
[http://openhpsdr.org/wiki/index.php?title=PiHPSDR_compile_rpi Compiling on Raspberry Pi OS (32 bit)]
+
[http://openhpsdr.org/wiki/index.php?title=PiHPSDR_compile_rpi_os Compiling on Raspberry Pi running RPi OS (32 bit)]
  
[http://openhpsdr.org/wiki/index.php?title=PiHPSDR_compile_ubuntu Compiling on Raspberry Pi Ubuntu 20.10 (64 bit)]
+
[http://openhpsdr.org/wiki/index.php?title=PiHPSDR_compile_ubuntu Compiling on Raspberry Pi running Ubuntu 20.10 (64 bit)]
  
Note: I would recommend to use a minimum of the the 4GB version of the RPi 4.
+
=== Running PiHPSDR ===

Latest revision as of 08:55, 3 December 2020

System Requirements

PiHPSDR is software designed to run on the Raspberry Pi using the official 7 inch touch screen. It can be compiled to include support for Rotary Encoders and Push Buttons using the GPIO pins and/or the i2c interface.

It can be compiled and run on most Linux and Apple Mac systems without using GPIO.

It is recommended to use a Raspberry Pi 4 with 4GB or 8GB of memory if running Ubuntu 64bit OS. The 2GB version will work OK using the Raspberry Pi 32 bit OS.

Compiling PiHPSDR

Compiling on Raspberry Pi running RPi OS (32 bit)

Compiling on Raspberry Pi running Ubuntu 20.10 (64 bit)

Running PiHPSDR